Q1:大神帮忙看看通达信技术指标有没有未来函数

MA30:=EMA(CLOSE,30);
强弱:EMA(CLOSE,900);
STICKLINE((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;
STICKLINE((MA30<强弱),MA30,强弱,1,0),COLOR00FF00;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
现价:CLOSE,COLORWHITE,LINETHICK1;
STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'★B'),COLORYELLOW;{吸}
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★'),COLORRED;{抛};
你这个公式中是没有任何未来函数的。

Q2:通达信公式没有未来函数,前几天的信号怎么会消失

问题出在“REFDATE(低,DATE);”,
REFDAY()函数的第二个参数必须是常数,而DATE却是个变量,于是就强制把DATE变为常量,返回DATE的最新值,对于几天前而言,DATE的最新值就是未来数据,于是就产生了引用未来数据的情况。
简而言之,应用了未来数据。
把它改为不应用未来数据的公式,如下:
N:=90;M:=3;
低:REF(LLV(L,N),M);
XG:低=L AND ((C-L)>(O-C) OR (O-L)>(C-O)) ,COLORYELLOW,LINETHICK5,STICK;

Q3:通达信公式中未来函数如何去除,请高手指点

解释不清楚,你把公式发上来,给你改了

Q4:通达信主力骗线指标是否有未来函数

要看过指标原代码才能确定,如果指标加密了就不好下决论。

Q5:通达信趋势买卖选股公式

你是想知道这些公式的意思呢还是想知道这些公式的其它信息呀?说一个半句话,我也不知道是啥意思。

Q6:通达信趋势买卖公式变成预警公式?

XMA是通达信未来函数!!!不建议用这个指标预警!!!